Microsoft Access 2003

Discussion in 'Off-Topic Chat' started by savewaterdrinkbeer, Mar 26, 2007.

  1. Hi, im a ICT Technician/Teacher at a school, some of the classes are having problems with the date format in access it is set as the american format, when i log on as administrator on the computer and change the settings, it does not keep the settings for when one of the kids log in and reverts back to the american setting.

    the kids do not have any access to change settings so must be done by administrator.

    does anybody have a clue of how to make this work??? i have been on microsofts website but cant find anything to help me.

    hope to hear from you soon
  2. DaveR

    DaveR Active Member

    You need Mike Lyons - he's an expert with all things Microsoft. Drop him a pm if he doesn't see this message, he's a very helpful chap! :tup
  3. i have downloaded office 2003 sp2 so i'll see if that makes any difference
  4. mikelyons

    mikelyons Supporting Member

    Couple of questions - how is the system formatting the date? Is your region set to UK or US? This makes a difference to a number of things that Access might pick up on.

    How are the kids setting up the date fields in the first place when they set up their tables? Are they using the wizard or doing it manually?

    Where is the problem cropping up? Tables? Reports? forms? Access pages?

    I have no problems on my Access 2003 at home. Some IT managers are lazy when distributing the Access package around the network and don;t use the UK settings! If you are using the US settings then you will get the US date format as well.

    Just my thoughts.

    If you sent me a copy of a database that is exhibiting the problem I might be able to work out the problem and a solution.
  5. the region is set to UK the format it is giving is mm/dd/yyyy i need it dd/mm/yyyy. According to microsoft there is nothing that can be done permantly the only thing is to set it on every database. if you can think of a solution then good luck as i've been playing around with it for a while. maybe you should apply for the networks managers job thats going at school, if you can solve this.

  6. mikelyons

    mikelyons Supporting Member

    I am absolutely certain that it is your windows region settings that are causing this. Are you absolutely certain that the little darlings aren't fiddling with them behind your back?

    I've just done a quick experiment, changing the international settings in control panel and it causes exactly the symptoms you describe. Access picks up its default date formats from windows, rather than using its own.

    You can override them individually, when you set up the date fields in the table, but the main 'switch' is in the control panel under 'Regional and Language settings'. Make sure it is set to English (UK) and that the number formats there are the ones you want. This should have been done at the deployment stage - unless you are living elsewhere ;) - but, as I said, some IT managers are lazy and just use the default settings which are USeless ;)
  7. done that checked the regional settings that are both set to English UK if i go on access as administrator it is the correct way dd/mm/yyyy, but when one of the kids logs in it changes back to mm/dd/yyyy. i have checked to see if there is anything in group policys but cant find anything to do with regions on the server. but office isnt run off the server it is loaded on to the machine.

    any other ideas?
  8. mikelyons

    mikelyons Supporting Member

    Is it all machines or just certain ones?

    I don't use access at work any more, but I seem to remember when setting up the music department machines that for software that was installed on each station rather than on a server, each log-on had to be set up individually or you had to have a group policy that set up each user in the group to use the settings you wanted.

    It doesn't happen in school - each user has English settings.

    Do the non-admin users have access to CP/Regions? Can you at least check, when a child is logged on, what its own settings are? If so, what does that show you?

    If you are using RM machines, can they not set up a policy for you for redistribution across your machines?

    I'll have a check with our techs. I think it's not access that is causing the problem though. This is Windows in control! :rolleyes:
  9. NeilW

    NeilW Member

    Have you set the local for all users (or just administrator).

    On the advanced tab of the Regional and Language options control panel app there is "Apply all settings to the current user account and to the default user profile".

    That's often what we forget to do when we're testing localisation :oops:


  10. mikelyons

    mikelyons Supporting Member

    I bet that's it. Good thought Neil!
  11. nope that doesnt work either, i have even done a full reload of a machine and made sure that all the default settings are english UK and it still says mm/dd/yyyy. its sending me nuts as its the correct way for administrator and the exam board are saying the date needs to dd/mm/yyyy. i have even phoned the exam board and they are clueless.

    does aybody know if its anything to do with active directory?
  12. DaveR

    DaveR Active Member

    Just a thought (I work on an IT support desk and I hate not being able to see the problem at first hand myself!) - could you enable remote assistance or VNC on one of these machines so that somebody could take a look at it?

    I'm not volunteering though as I don't know very much about Microstuffed config, and even less about Access - I'm merely sticking my nose in! :biggrin:
  13. smiler_38

    smiler_38 Member

    Is this on XP? If it is check the ControlPanel-> Regional and Language Settings is definately set to English(United Kingdom) and that the Short Date box shows the correct dd/mm/yyyy. If not check the Customize... Date has not had the Short Date format changed from dd/MM/yyyy.
  14. WCB_Sop

    WCB_Sop New Member

Share This Page