Laptop DVD player

Discussion in 'Off-Topic Chat' started by Di, Mar 26, 2007.

  1. Di

    Di Active Member

    Hi all.

    I'm having trouble (again) with the playback on DVDs. This has happened before, just before Christmas, and having tried the DVD trouble shooting guide, DVD cleaner, we called the Tosh helpline. He told Steve to uninstall and reinstall the drivers. This cleared the problem and all ran fine again.

    For a few weeks.

    Now DVD playback is jittery and the sound is stuttering and echoy. I've tried all the trouble shooting again and have uninstalled and reinstalled the drivers as directed before, but this has not fixed the problem this time. I've tried googling the problem and have found several like myself on the Tosh help forum, but have not found the answer.

    Can anyone help me please. My warranty ran out in January, so there's no sending it back now to be fixed (well, not without a hefty bill anyway. :rolleyes: )

    Thank you.
  2. six pints

    six pints Active Member

    download VLC player!
  3. Di

    Di Active Member

    Hmm, could do, but I already have Intervideo WinDVD, Real player, Windows Media Player and Power DVD. And it doesn't work with any of them, so I'm not anticipating it choosing to work with a different program.

    Going to try running the cleaning disk again, although I don't think this is the issue either, but hey, it's worth a shot.
  4. SuperMosh

    SuperMosh New Member

    Have you tried restoring to an earlier windows point? Had the sanme trouble with mine (Fuji Siemens) and did the trick. I think.
  5. Di

    Di Active Member

    Hmm, worth a try. I've had troubles in other areas after letting Windows install its updates. I've been clicking "remind me later" for a few days now on one it's been trying to install (and no, these updates were offered after the problems began with the DVD). Anyway, my cleaning disk has just told me cleaning is complete, so lets have a looksee.

    Edit : Nope. :(
  6. johnmartin

    johnmartin Active Member

    I suspect that this is a software issue but to rule out hardware, can you borrow a USB external DVD drive and try that.

    Other possibilities are that you may inadvertandly be using software to do the decoding rather than hae the graphics card do it. This would put a lot of strain on the CPU and could result in the jittery sound.
  7. Di

    Di Active Member

    'fraid I haven't got one of those. :(
    How would I find out if I'm inadvertantly doing that? :confused:

    I haven't, as far as I know, changed any settings. One day it was working, the next it was not. :(
  8. andyp

    andyp Active Member

    Here's one idea - DMA settings on the DVD drive:

    Also check the graphics hardware acceleration settings (should be full).

    Most laptops use the system memory for graphics as well, not having separate graphics cards like desktops. There is a setting somewhere that you can alter how much it uses/is allowed to use, but I'm not 100% sure where it is, probably in a sub-menu of Device Manager at a guess.

  9. Di

    Di Active Member

    Thanks Andy. I've already checked the DMA settings as part of the trouble shooting process and they are correct.

    Off now to search for this graphics thingy you mention. ;)
  10. Di

    Di Active Member

    Aha! :biggrin:

    Have tried again and again uninstalling and reinstalling the DVD drive, but we've just gone mad and uninstalled the secondary IDE driver as well as the DVD driver, rebooted and turned on the DVD.

    Voila! Wahay... No more horrible echoey chamber sounds. :biggrin::biggrin:

    Thanks all for your suggestions.

    Edit : Ooop, and thanks to my darling husband too. :roll::rolleyes:

    Jeez, never post with someone looking over your shoulder. ;)
  11. johnmartin

    johnmartin Active Member

    Sometimes Windows is just plain weird.

    Glad to hear it's back working Di. Now, make a system checkpoint here so you can return to this hardware config if necessary.

Share This Page